Version 1.14 Upgrade

Here is the package for upgrading the Vectrex32 firmware to version 1.14:

Vectrex32 upgrade 1.14

You must have Vectrex32 version 1.10 or newer in order to use this upgrade package. If you have version 1.00, see this post in the forums for instruction on upgrading.

Download the package to your computer, unzip it, and follow the instructions in Readme.txt.

For more information about this upgrade, see the Version 1.14 Documentation post.

Version 1.13 Upgrade

Here is the package for upgrading the Vectrex32 firmware to version 1.13:

Vectrex32 upgrade 1.13

You must have Vectrex32 version 1.10 or newer in order to use this upgrade package. If you have version 1.00, see this post in the forums for instruction on upgrading.

Download the package to your computer, unzip it, and follow the instructions in Readme.txt.

For more information about this upgrade, see the Version 1.13 Documentation post.

Version 1.12 Upgrade

Here is the package for upgrading the Vectrex32 firmware to version 1.12:

Vectrex32 upgrade 1.12

You must have Vectrex32 version 1.10 or newer in order to use this upgrade package. If you have version 1.00, see this post in the forums for instruction on upgrading.

Download the package to your computer, unzip it, and follow the instructions in Readme.txt.

For more information about this upgrade, see the Version 1.12 Documentation post.